MUSTER Environment Variable

Viewing 4 posts - 1 through 4 (of 4 total)
  • Posted in: Mac OS X
  • 16th October 2009 at 8:28 am #14342


    I am trying to get Muster up and running to work with Maya on my mac pro, osx 10.5.8.
    But I seem to get stuck setting the MUSTER environment variable correctly.
    EDIT: I am currently trying the V6beta but I had exactly the same problem getting v5 to work.

    In my ~/.cshrc that I use for other apps I have the line

    setenv MUSTER /Applications/Muster/Contents

    i have also tried

    but nothing seems to stop me getting error messages telling me that

    sh: Mrtool: command not found

    I have tried rebooting and starting maya from fresh shells.

    Any ideas what I am doing wrong?


    20th October 2009 at 10:34 am #15015

    Hi again,

    this is now solved together with a whole bunch of other things I needed to know to get Muster to work on my Mac.
    I got help through the support contact email.


    19th August 2010 at 7:35 pm #15094

    I know this is a dated post, but I am having a similar issue and just wrote to the support email only to get the notice that they are on vacation. I’ll paste the email in here and hopefully someone can help me out.

    All in all everything is working very well with 2 slaves currently. I can send jobs with the console just fine, however I can not seem to get the Maya connector plugin to work properly. I’ve read the setup page on p114 of the Muster 6.0.4 User Manual. I set up my Maya.env to be for Maya only at first.

    Running MacOs 10.6.4 and Maya 2011×64

    per these instructions:,topicNumber=d0e675177

    In this file:

    with these permissions:
    -rw-r–r– 1 hour6 staff 56 Aug 18 14:32 Maya.env

    I added this line:
    MUSTER = /Volumes/MYDRIVE/Applications/Muster/Contents/

    Restarted Maya then in MEL command line tried:
    loadNewShelf “shelf_Muster.mel”;

    and got:
    // Error: File not found. Invalid name or script not along script path. //

    I assumed the ENV var wasn’t working properly so I tried:

    and got:

    // MYDRIVEPATHSTUFF/mel:/Users/MYUSER/Library/Preferences/Autodesk/maya/2011-x64/scripts:/Users/hour6/Library/Preferences/Autodesk/maya/scripts:/Users/hour6/Library/Preferences/Autodesk/maya/2011-x64/presets:/Users/Shared/Autodesk/maya/2011/scripts:/Users/Shared/Autodesk/maya/scripts:/Users/hour6/Library/Preferences/Autodesk/maya/2011-x64/prefs/shelves:/Users/hour6/Library/Preferences/Autodesk/maya/2011-x64/prefs/markingMenus:/Users/hour6/Library/Preferences/Autodesk/maya/2011-x64/prefs/scripts:/Applications/Autodesk/maya2011/ //

    None of which had the Muster path.
    I also tried adding the lines
    MUSTER = /Volumes/MYDRIVE/Applications/Muster/Contents
    MUSTER = /Volumes/MYDRIVE/Applications/Muster/Contents/mrtool
    MUSTER = /Applications/Muster/Contents/

    None showed up in get env and were reporting the same error.

    So i tried to add it to the OS ENV Var instead.

    create this file:

    MUSTER = “/Applications/Muster/Contents/”;

    and same errors in Maya after restart
    also tried:
    MUSTER = “/Applications/Muster/Contents/mtool”;
    MUSTER = “Volumes/MYDRIVE/Applications/Muster/Contents/”;

    I added the shelf using the full path to the shelf file instead, and the icons and script references sort of worked when i clicked them.

    but… then i tried to source mel.
    source “MusterConnector.mel”

    and got:
    // Error: source “MusterConnector.mel”; //
    // Error: Cannot find file “MusterConnector.mel” for source statement. //

    I looked everywhere for the file MusterConector.mel file and couldn’t find a trace of it. I also installed the windows version and tried to look for it in there to copy it over and couldn’t find anything.

    I tried to run it anyway and.
    it keeps giving me the check textures error
    so under the images tab I hit reload textures and it pulls up my textures just fine. In the texture Image name in Maya they are relatively linked..
    Then I hit conform texture and get this error:
    // Error: Object ‘MS_OutputText’ not found. //

    I assume its because the MusterConnector.mel was not sourced since the environment var doesnt seem to be properly set up.

    My hardware setup is as follows:
    MacBook Pro 17 8GB Ram Solid state drive for the master dispatcher.
    2 macpro 8 core machines for slaves 10.6.
    dual G5 MacOs 10.5.8 as fileserver

    7th September 2010 at 2:59 pm #15116

    The connector has been updated in the latest 6.0.8 to support Maya 2011!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.